Comment installer TrueCrypt 7.1a sous macOS quand on rencontre l’erreur « TrueCrypt requires Mac OS X 10.4 or later. » ?

J’ai voulu réinstaller TrueCrypt 7.1a sur mon macOS et après l’avoir téléchargé ici, je me suis heurté à l’erreur suivante :


TrueCrypt requires Mac OS X 10.4 or later.

Pas cool, sachant que la version actuelle de macOS est la 10.13.4.

Heureusement, il existe un moyen de contourner le problème. Voici comment.

Etape 1, copiez le fichier TrueCrypt7.1a.mpkg sur votre disque dur. Faites ensuite un clic droit dessus et faites « Afficher le contenu du paquet »

Rendez-vous ensuite dans le dossier « Contents » et éditer avec Textedit ou l’éditeur de texte de votre choix, le fichier distribution.dist.

Repérer ensuite les lignes que j’ai surligné dans la capture écran ci-dessous. Il s’agit du code qui vérifie la version de votre macOS et qui empêche TrueCrypt de s’installer. Vous pouvez supprimer tout ce que j’ai surligné ou simplement modifier les valeurs.

Sauvegardez le fichier, et relancez l’installation du package comme au début.

Problème résolu !


Security Guardian – Pour surveiller la sécurité de vos serveurs

Vous permet d’établir une liste de serveurs ou de sites web à scanner régulièrement et automatiquement pour y détecter d’éventuelles vulnérabilités

Le scanner Security Guardian se destine donc aux webmasters et entreprises qui n’ont pas forcément de connaissances techniques en matière de sécurité, mais qui souhaitent tout de même améliorer leurs défenses face aux cybercriminels et anticiper d’éventuels problèmes de sécurité.

Lorsqu’un scan est effectué par Security Guardian, chaque vulnérabilité détectée est classifiée selon son niveau de criticité et vous êtes immédiatement alerté par email.

En Savoir +


Korben